Since & Until Params Not Working

Issue No. 155

Type

Bug

Status

Closed

Reported By

kat padilla

Component

API

Resolution

Not a Bug

Votes

0

Created

3/Dec/13 12:33 AM EST

Closed

6/Dec/2013 7:32 PM EST

Description

Say I am getting the Lakers' schedule from December 1st only, the since param is not working. It is still returning the sched/results from day 1. /nba/results/los-angeles-lakers.json?order=desc&since=20131201

Closing Comment

Another way to see what data is being returned is to remove the ".json" (i.e., /nba/results/los-angeles-lakers?order=asc&since=20131201&until=20131207). This returns an HTML view which you can load in your web browser without passing an access token. Closing this since it looks like the since and until parameters were not being sent to the server. If you disagree, free to open another issue.

Comments

1. Erik Berg 3/Dec/2013 at 1:01 AM EST

Using the URL you listed, events are returned from the latest scheduled (in this case, April 16, 2014) to December 1, 2013. This is the expected output. Is the API doc unclear? Let me know, so it can be updated. /api/methods/team-results

2. kat padilla 3/Dec/2013 at 2:48 AM EST

Hmmm, even if I put, say: /nba/results/los-angeles-lakers.json?order=asc&since=20131201&until=20131203 It still doesn't show Dec. 1 to Dec 3 of this season. It shows everything.

3. Erik Berg 3/Dec/2013 at 10:32 AM EST

If you are running on Linux/OS X, make sure you either surround the URL with quotes or escape the &, otherwise the shell will spawn a subshell and run the command (up to the first &) in the background. In that case, your since and until parameters are never sent to the server, so everything is returned. curl -H "Authorization: bearer xxx-xxx-xxx" "https://erikberg.com/nba/results/los-angeles-lakers.json?order=asc&since=20131201&until=20131203"