NBA team data for scores returning -1

Issue No. 161

Type

Bug

Status

Closed

Reported By

Jackson Geller

Component

Wrong/Bad Data

Resolution

Not a Bug

Votes

1

Created

29/Jan/14 11:21 PM EST

Closed

30/Jan/2014 9:14 PM EST

Description

Hey I'm trying to return all of the Wizards scores to date this year, but I'm encountering two problems. One, it's not recieving the latest game, it's a couple of games behind. I don't know if this is the nature of the api or a bug. Secondly, when as I get to the latest games returned, the scores return -1, instead of regular scores like 85 to 84. Here's an example http://pastebin.com/XBWV90Lq here's my request /nba/team/washington-wizards/results.json?season=2014

Closing Comment

See comment below. Also, just noticed that your request URL is using a deprecated request path which has been replaced. Please refer to the documentation. /api/methods/team-results

Comments

1. Erik Berg 29/Jan/2014 at 11:59 PM EST

If I knew the scores and outcomes before the games were completed, this site would be the biggest sports book in the world! When you encounter "-1" values for scores, it is most likely because the game has not taken place yet. The Results method returns the full 82-game season unless "since" and "until" parameters are specified. Events are returned from the latest to the earliest by default, so the first event you will see (and the one in your pastebin) from your request is the final Wizard's regular season game on April 16, 2014. The full documentation for the method is here /api/methods/team-results If it can be made clearer, let me know and I will update it...