MLB roster always returns 40-man roster

Issue No. 197

Type

Bug

Status

Closed

Reported By

Rinke Riezebos

Component

API

Resolution

Not a Bug

Votes

0

Created

10/Jan/15 11:00 AM EST

Closed

10/Jan/2015 9:11 PM EST

Description

Hi Erik, Great job! I was just looking into the roster query options for the MLB and trying to create a method as well for the ruby library. However I noticed that the url query always returns the 40-man roster (including the non-active players). This differs from the suggestion on /api/methods/roster, where it says it will return 25-man roster unless I add ?status=expanded to the end of the query. Keep up the good work!

Closing Comment

The MLB rosters are only updated through the beginning of December. However, since September (excluding playoff rosters), the active roster expands to 40 players. Teams will name their 25-man roster and 40-man roster before Opening Day. At that time, you will see a difference using "status=expanded".